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What is Artisteer? 

Artisteer is the first and only Web design automation product that instantly creates fantastic looking Website 

and Blog templates. It is a powerful software that makes YOU a professional Web designer of Websites, 

WordPress themes and blog templates. It lets you create fantastic looking Website designs and templates 

in just minutes, without having to know anything about editing graphics or HTML.  

 

With Artisteer YOU immediately become a Web design expert, editing and slicing graphics, coding XHTML 

and CSS, and creating CMS templates and WordPress themes - all in minutes, without Photoshop or 

Dreamweaver, and no technical skills. 

Use Artisteer to generate cool Web design ideas, adjust the generated designs using many included 

elements, backgrounds, photo objects and buttons, create professional, tableless, cross browser 

compatible and fully compliant HTML and CSS code and export your design to create great looking Web 

and Blog templates. 

Creating great designs has never been easier! 
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How to work with the Artisteer interface? 

The Artisteer interface is quite simple to learn. There are several main items: Main Menu, Quick Access 

Menu, Tabbed Navigation Bar and Design Preview (highlighted on the image below). 

Main Menu contains basic file commands, recent documents and other standard items for File menu. 

Quick Access Menu contains Undo, Redo, Save and Open shortcuts. 

Navigation Bar contains all available editing tools.  

Design Preview lets you see how your design will look like. All links and buttons on preview are non-

clickable. 

 

Quick Access Toolbar Main Menu Navigation Bar Design Preview 
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Quick Access Toolbar 

The Quick Access Toolbar is a customizable toolbar that provides the ability to create one-click shortcuts to 

frequently used commands and quickly perform the most common tasks.  

By default, the Artisteer Quick Access Toolbar contains the Open, Save, Undo, Redo and Export 

commands. But you can customize the content of the toolbar adding or removing items as you like.  

To add a new item, right click on the desired command button in the Navigation Bar and select "Add to 

Quick Access Toolbar" option. 

To remove the item, right-click on it and select "Remove from Quick Access Toolbar" option. 

Note: Not all the commands located in the Navigation Bar can be added to the Quick Access Toolbar, for 

some commands "Add to Quick Access Toolbar" option in the right click menu is disabled. 

By default the Quick Access Toolbar is located above the Navigation Bar. To place it beneath the 

Navigation Bar, click a small arrow button on the right end of the toolbar (or simply right-click within the 

toolbar or Ribbon area) and select “Show Quick Access Toolbar Below the Ribbon” option from the drop-

down menu. 
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Quick Start Guide 

Downloading Artisteer 

You can download the Artisteer installation file from the official Artisteer Web site at 

http://www.artisteer.com. The software is provided with a free trial period that allows you to evaluate the 

product before purchasing. During this period of time Artisteer is fully functional and has all its features 

available for testing. The only restriction is that all the templates and images generated with Artisteer will 

have watermarks on them until the product is activated. The trial period is unlimited so you can activate the 

software at any time you wish and activation instructions are provided in the Activating the Software 

chapter. 

System Requirements 

This section describes the system requirements for the Artisteer software.  

Development Environment 

 Intel or AMD processor 1500 Mhz or higher 

 100 Mb free disk space 

 512 Mb RAM or higher 

 Microsoft Windows 2000, XP, Vista 

 Microsoft .NET Framework 2.0+. It can be obtained from the Microsoft website at: 

http://www.microsoft.com/downloads/details.aspx?familyid=0856eacb-4362-4b0d-8edd-

aab15c5e04f5&displaylang=en 

Browsers supported 

 Internet Explorer 6+ 

 Firefox 2+ 

 Opera 9+ 

 Safari 1+ 

 Google Chrome 1+ 

http://www.microsoft.com/downloads/details.aspx?familyid=0856eacb-4362-4b0d-8edd-aab15c5e04f5&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=0856eacb-4362-4b0d-8edd-aab15c5e04f5&displaylang=en
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Technologies supported 

 CodeCharge Studio 4 

 WordPress (2.5-2.7) content management system  

 Joomla 1.5 content management system 

 Drupal (5.x, 6.x) content management system 

Standards supported: 

 XHTML 1.0 Transitional 

 CSS 2 

 Section508 (partially) 

 PNG with transparency 

Installing Artisteer 

This chapter describes how to install Artisteer on your computer.  

Before you proceed please make sure that your computer meets the requirements listed in the System 

Requirements chapter. 

1. Log into Windows as a Power User, or assume the Primary Administrator role.  

2. Double-click the installation file called ArtisteerInstall.exe. This will launch a standard installation 

process.  

3. Select the language that you’d like to use during the installation. Click Next button. 

4. Follow the instructions provided by the installation wizard. 

5. Carefully read the License Agreement. If you accept its terms, check "I Accept the terms of the License 

Agreement" option and proceed to the next step. Otherwise, quit the installation. 

6. Select the destination folder where you want to install the product. 

7. Indicate whether you want to create shortcut icons on the desktop and Quick Launch panel. 

8. Click Install button to start the installation. 

9. Click Finish button when the installation is complete. 
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Activating the software 

After you’ve purchased Artisteer you will receive a Serial Number to be used to activate the software. The 

activation removes the watermarks added to the generated templates by the trial version. 

To activate the product click on the Palette icon to open Artisteer Activation dialog and enter your serial 

number in the first box. If your computer is connected to the internet, check "Auto-activation through the 

internet" option and click the Activate button.  

If you work off-line use the following link to obtain the activation key from any other computer connected to 

the web: 

http://www.artisteer.com/?p=a 

In this case uncheck the "Auto-activation through the internet" option and enter the obtained activation key 

directly in the Activation Key box. 

 

Restart Artisteer after you successfully complete the activation process. 

http://www.artisteer.com/?p=a
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Creating a basic design 

Creating a design with Artisteer is as easy as 1-2-3: 

 

In most cases, nearly everything you need to do can be started by clicking on the Suggest Design button. 

This creates a random design that you can either work on or click again to see another suggested design. 

1.Suggest Design 

is a tool to find  a 

basic theme idea and 

the great place to 

start from.  

 

2. When you find a 

good design idea you 

may want to adjust some 

design elements like 

colors, fonts or page 

background separately. 

The corresponding 

“Suggest …” buttons 

will help you with this. 

 

3. Click Export 

to save the created 

design as a 

WordPress theme, 

HTML template or 

any other format 

you like. 
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Further customization 

Artisteer is a powerful tool with great customization capabilities. After you find a good design idea you may 

go into a specific tab and adjust the design to match your needs.  On each tab there are several options for 

customizing specific elements. 

Note: Some options may not be available depending on settings and layout choices you have made in other 

areas. 

That is not all! If you can’t find the option you want in specific list then click on “More…” to get full 

customization capabilities: 

Here is an example of how it looks for the Sheet tab: 

 

Even more 

options here… 
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Dialog boxes 

Many options and settings are included in the dialog boxes which can be accessed by clicking a small arrow 

button  to the right of the group caption.  

 

The user interface for a typical dialog box includes the following parts: 

 Dialog caption indicating what kind of options are available in the dialog 

 The list of the option groups located in the left pane of the dialog box. Click on the group to expand 

its options. 

 Options and settings available for the selected group. 

 Preview checkbox to view the results of the setting automatically as they are changed. 

 Preview button to display the result of the settings on the page. 

 OK button to apply the settings and close the dialog box. 

 Cancel button to discard the changes and close the dialog box. 

An example of a dialog box is provided in the picture below. 
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Most of the dialog boxes contain settings that can be changed using slider bars. Usually these are settings 

for the width, height, opacity, transparency and other range values. Position the pointer over the slider and 

drag it to the right or left to increase or decrease a specific option’s value. The selected value will be 

displayed in the box next to the slider bar. You can also enter the desired value directly in this textbox. 

Use the "Preview" button or "Preview" option available at the bottom of the dialog window to preview the 

changes.  

If the "Preview" checkbox is ticked, the changes will be immediately displayed on the page as you drag the 

slider. If you type the value directly in the option box, click outside the box to have the value applied to the 

page.  

If the "Preview" option is unchecked, press Preview button to see the changes on-screen. It will help you 

easily achieve the desired look of your page. 

Finally click OK or Cancel button to commit or discard your changes.
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Color Selector dialog 

The Color Selector dialog is displayed when you select "More Colors…" button in one of the color option 

dialogs.  

 

The Color Selector dialog lets you select the desired color and adjust the hue, saturation, and brightness of 

this color.  

There are Luminosity and Hue tabs available in the dialog. Both tabs have a color selection area (color 

palette) where you can move a slider until you are satisfied with the color.  

On the Luminosity tab there is a special luminosity slider. This slider lets you increase or decrease the 

brightness of the color from zero at the bottom to 100 at the top of it. 

With the luminosity selected, you can go to the color palette and drag a small circle picker horizontally and 

vertically to change the hue and saturation of the color respectively. 

The Hue tab contains a separate Hue adjustment slider. Moving it all the way from red (at the bottom) 

through orange, yellow, green, blue up to purple allows you to select the desired hue of the color.  

Having the Hue selected, you may also move a palette color picker from left to right and from top to bottom 

to additionally set the saturation and luminosity values of the color. Saturation can vary from 0% (completely 

unsaturated) to 100% (completely saturated, pure color). Luminosity ranges from 0 (black) to 100% (white). 
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The values displayed in the right set of boxes will change to indicate the exact color settings. These values 

can also be changed manually, directly in the text boxes. It may be convenient when you copy the exact 

color value from some other graphic software and want to use it in Artisteer.  

Property Description 

Hue Hue value of the color ranged from 0° to 360°. 

Sat Saturation of the color ranged from 0% (completely desaturated) to 

100% (fully saturated). 

Lum Luminosity of the color measured in percentage: from 0 (black) to 100% 

(white). 

Red Decimal value for red color. 

Green Decimal value for green color. 

Blue Decimal value for blue color. 

Hex A hexadecimal color code (usually used in HTML code). 

The "Preview" option makes it possible to see the page with the selected color applied to it. 

Ok and Cancel buttons allows you to submit or discard the changes made. 

Working with colors 

The colors on computer monitors are made up of varying amounts of red, green and blue base colors. 

Depending on how much you take from each base color, you can create any of the colors which a monitor 

can display. For example, a mix of red and green produces yellow color, a mix of red and blue – magenta 

and so forth. Mixing all three base colors with full intensity produces white color while the absence of all the 

components returns black color. 

The values for red, green, and blue base colors are usually specified using a scale from 0–255 (decimal), 

where 255 represents 100% intensity of the color. 

RGB is a convenient color model for computer graphics because the human visual system works in a 

similar way. However human perception does not see colors as triplets of numbers: red, green and blue. 

Instead it is quite convenient to describe colors as made up of hue, saturation and lightness (or luminosity). 

This HSL scheme defines colors more naturally and can be visualized as a cylinder whose central axis 

ranges from black at the bottom to white at the top with neutral colors between them, where angle around 
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the axis corresponds to “hue”, distance from the axis corresponds to “saturation”, and distance along the 

axis corresponds to “lightness”, or “luminosity”.  

 

Hue specifies a pure, spectral color. It is measured as a location on the color wheel, expressed as a degree 

between 0° and 360°. In common use, hue is identified by the name of the color such as red, orange, or 

green. 

 

Hue Color 

0 red 

1 yellow 

2 green 

3 cyan 

4 blue 

5 magenta 

6 red 

Saturation is the purity of the color. It represents the amount of grey in proportion to the hue, measured as 

a percentage from 0% (grey with no hue at all) to 100% (fully saturated color). On the standard color wheel, 

saturation increases from the center to the edge.  

Luminosity (Lightness): is the relative lightness or darkness of the color, usually measured as a 

percentage from 0% (black) to 100% (white). 

Artisteer allows you to work with both HSL and RGB color schemes. The desired color can be specified in 

the Color Selector dialog. 
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Navigation Bar 

Let’s have a closer look at the navigation bar. It is divided into eleven different distinct categories used to 

customize your design.  Moving from left to right, we begin with the overall idea and layout to the site.  As 

we move to the right, we become focused on specific parts of the site such as blocks and buttons. 

 

1. Ideas 

The Ideas tab is a great way to quickly envision your Website design right before your eyes.  

 

1.1. Creating Your Design 

Let Artisteer create design for you. The Suggest design feature is best used at the beginning.  It allows you 

to see the various designs available and helps you determine which styles and themes you like. 

 

1.2. Making Adjustments 

You are able to make adjustments to many individual components when brainstorming ideas for your Web 

design: 
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 Possibly the font doesn’t match the layout of the site or the buttons don’t match the navigation.   By making 

these adjustments, you can get closer to the look that you want to achieve. 

Export Design 

Once you have settled on the basic look of your site, you can export it as a design or template which is 

compatible with the type of blog, CMS or application that you want to use. 

 

There are three steps that need to be followed to export the design: 

1. First, select a template which will be applied and used when viewing the page in Artisteer. Currently 

the following templates are available: Website Design, WordPress, Joomla, Drupal, Visual Studio 

and CodeCharge Studio.  

2. Next, tell Artisteer what export option you want to use when generating the selected template. 

Choose the desired Export Design option to export and save your design as individual style files.  

3. In the Export Dialog, specify the desired template name and the folder to export your template files 

to. If necessary, compress the template folder by using "Export as a ZIP archive" option. 
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Option Description 

Name Identifies the name of your theme. It is recommended that the name 

should conform to the naming conventions of the CMS used. 

Path Indicates the path to the folder where the exported files should be placed. 

Export as a folder When the template is exported, a folder with the specified name 

containing all the theme files.is created in the specified location.  

Export as a ZIP archive When the template is exported, a zip archive containing all the theme 

files.is created in the specified location. 

Export Options Dialog 

The Export Options dialog box appears when you select Export > "Export Options..." from the Main Menu or 

use the Export > "Export Options" command on the Ideas tab or on the Quick Access Toolbar. The dialog 

provides a set of options for exporting templates from Artisteer.  

The available options are explained below. Most of them are optional; no value is assigned when a field is 

left empty. 
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Properties tab 

Describe the information to be used by Artisteer to generate the style sheet header and the metadata 

information for the theme. This information will be further used by CMS, if your CMS supports such 

functionality. 

Property Description 

Author Name Identifies the name of a person or organization creating the design. 

Author URL Provides the reference to the Author's website 

Show Author in Footer When checked, the above-defined Author Name will be displayed in the 

page footer. 

Template Version Identifies the Version Number of the template. 

Template URL Specifies the location of the template on the web. 

Tags Specifies the keywords associated with the theme. 

Description Provides additional information about the theme. 

WordPress Tab 

Contains a Home Page Menu Item settings which specify whether Artisteer should create a special menu 

item pointing to the homepage (front page) of the website. 

Property Description 

Visible Item If this option is checked, Artisteer creates a special Home Page Menu Item 

which is highlighted when the website’s front page is displayed in a 

browser. If the front page is not set, this menu item points to the list of 

posts. 

If "Visible Item option is unchecked, no menu items are created by 

Artisteer. The whole menu is built from the list of WordPress pages. If the 

front page is specified in WordPress settings, you will see the menu item 

that corresponds to that page added and highlighted in the menu. If the 

front page is not set, no menu item is highlighted by default when the list of 

posts is displayed in a browser. 

Item Name Specifies the caption of the menu item pointing to the home page. 
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Watermark Tab 

Property Description 

Show Watermark If checked, the Watermark Text will be repeated throughout the page. 

Watermark Text A text to be displayed across the page when the "Show Watermark" 

option is enabled. 

Export Design options 

Now let us consider every Export Option in a little more detail. 

Icon Option Description 

Content Management System Theme 

 

WordPress WordPress template option is provided for those who create 

designs for WordPress websites.  

After selecting this template from the Template list you have 

options to export the design as an HTML template or a 

WordPress theme. 

 

Joomla Joomla template option is provided for those who create 

Joomla website designs. 

Selecting this option provides the possibility of exporting your 

design as an HTML or Joomla template. 

 

Drupal Drupal template option is provided for those who work with 

Drupal CMS. 

Selecting this option allows exporting your design as an HTML 

template or Drupal theme. 

HTML Template 

 

Company Homepage  This template can be selected if you don’t use any particular 

CMS (content management system) but want to create a 

professional css design for your website.  

Web Developer Template 

 

ASP.NET Application ASP.NET Application option is provided for .NET developers 

creating websites in MS Visual Studio.  

The design can be exported as an HTML template or as a 
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Visual Studio C# project. 

 

CodeCharge Studio CodeCharge Studio template option is provided for 

developers and designers who use CodeCharge Studio 

development tool for creating web applications.  

After selecting this template from the Template list, you have 

options to export the design as an HTML template or as a 

CodeCharge Studio Project. 

Exporting a design as a WordPress theme 

To export a design as a WordPress theme that can be applied to the existing WordPress installation follow 

these steps: 

1. Select Template >WordPress template. 

2. Select Export >”WordPress Theme" option. 

3. Specify the desired name and path to the folder to export your template files to. If necessary, you 

can compress the template folder by using "Export as a ZIP archive" option. 

After the export you will obtain WordPress-specific theme files that can be located in the theme folder on 

server and easily applied to the WordPress websites. The path to the theme folder in WordPress system 

usually looks like WordPressFolder\wp-content\themes\ThemeName so you can simply upload the exported 

theme files into that folder.  

To apply the new theme to your website, login to the WordPress Administration Panel, navigate to the 

Presentation tab (WordPress version 2.6) or to the Appearance > Theme (WordPress version 2.7) and 

activate this theme. 

The generated WordPress themes are widget ready and compatible with WordPress version 2.5 and 

higher. 

Tips and Tricks:  

1. WordPress theme localization 

When exporting themes Artisteer automatically includes several language files obtained from WordPress 

Website at http://codex.wordpress.org/WordPress_Localization 

http://codex.wordpress.org/WordPress_Localization
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Specifically French, German, Italian and Spanish translations are exported by Artisteer in the WordPress 

compliant file naming format: 

<country>_<lang>.mo 

For example German language file is: de_DE.mo 

To include a different or additional language support in your Worpdress theme please find and copy the 

desired language files into your specific WordPress theme folder. You can find the additional language files 

in your default theme folder "<WordPressFolder>\wp-content\themes\default", or on the WordPress Website 

at http://codex.wordpress.org/WordPress_Localization 

To select a different language than your current WordPress language, change the "define" function in the 

wp-config.php file, for example:  

define('WPLANG', 'de_DE') 

To edit translations for your language please download and install Codestyling Localization plug-in from 

http://wordpress.org/extend/plugins/codestyling-localization/  

Then in WordPress administration select Manage -> Localization. 

Exporting a design as a Joomla theme 

To export your design as a Joomla template follow the steps below: 

1. Select Template > Joomla option. 

2. Use Export > “Joomla Template”. 

3. Specify the name and select the folder you want to export the template files to.  Alternatively, you 

can choose to compress the template folder by using "Export as a ZIP archive" option. 

After the export you will obtain a set of Joomla-specific files that can be located in the theme folder on 

server and easily applied to the Joomla websites. The path to the theme folder in Joomla system usually 

looks like JoomlaFolder\templates\ThemeName so you can simply copy/upload the exported theme files 

into that folder.  

http://wordpress.org/extend/plugins/codestyling-localization/
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If your theme is exported as a ZIP archive, log into the back-end of your Joomla installation, go to 

Extensions > Install/Uninstall, choose "Upload Package File" option in the "Extension Manager", type the 

path or click the "Browse..." button to select your zip file and click the "Upload File & Install" button to 

upload and install the theme. 

Once the theme is successfully installed, you can activate it selecting Extensions > Template Manager from 

the drop-down menu and assigning your template as the Default Template for the website. 

Note, that the generated Joomla themes are compatible with Joomla version 1.5 and higher. 

Tips and Tricks: 

1. Joomla localization 

Joomla provides internationalization feature and currently supports 50 world languages. The language 

packages are available for download at: 

http://joomlacode.org/gf/project/jtranslation/frs/ 

Joomla uses three language packages: one for the front end, one for the administrator and one for 

installation. It is not required to use all three. Feel free to download only the necessary packages and 

customize the language settings to serve your needs. 

If there are no packages for your language, you can create them manually following the instructions 

provided in Joomla documentation: 

http://docs.joomla.org/How_to_create_a_language_pack 

2. Apply Artisteer style to Joomla menu 

To apply Artisteer menu style, you should locate your menu in the "user3" module position For this go to 

Extensions > Module Manager > select the Menu (e.g. Top Menu) > click the Edit icon on the toolbar > 

Details section > select "user3" in the Position listbox. 

3. Multilevel Menu in Joomla 

It takes three steps to create a multilevel menu in Joomla: 

http://joomlacode.org/gf/project/jtranslation/frs/
http://docs.joomla.org/How_to_create_a_language_pack
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1. Activate a multilevel menu for your template in Artisteer (Menu > Subitem > Subitem > Levels > 

Multilevel option). 

2. Locate your menu in user3 module position in Joomla Administrator. 

3. Go to Joomla Extensions > Module Manager > select the Menu (e.g. Top Menu) > click the Edit 

icon on the toolbar > and set "Always show sub-menu Items" in the Module Parameters dialog to 

"Yes". If necessary, you can also specify the number of sublevels using "Start Level" and "End 

Level" options. 

Exporting a design as a Drupal theme 

To export a design as a Drupal theme follow the steps below: 

1. Select Template > Drupal. 

2. Use Export > “Drupal Theme” option. 

3. Specify the template name and select the folder you want to export the template files to.  If 

necessary, apply zip compression using "Export as a ZIP archive" option. 

After the export you will obtain a set of Drupal-specific theme files that can be located in the theme folder on 

server and easily applied to the Drupal websites. The path to the theme folder in Drupal system usually 

looks like DrupalFolder\themes\ThemeName, so you need to upload the exported theme files to that folder. 

If your theme is exported as a ZIP archive, extract the archive into the "themes" folder on server. 

After that, you can activate your theme in the Drupal Administration. For this, log into the administration 

area, navigate to Administer > Site Building > Themes, check the "Enabled" box as well as the "Default" 

radio button next to your template and click the "Save configuration" button. 

Tips and tricks: 

1. Naming standards 

Use only letters (preferable lowercase), numbers, and underscores in the theme name. No special 

characters, spaces or hyphens are allowed. 

If you work with Drupal version 5, be sure not to rename your template folder after the export. Otherwise, 

some functions will be undeclared and the design will look corrupted. 
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2. Drupal Localization  

The localization feature is described in the Drupal documentation:  

http://drupal.org/node/133977 

Exporting a design as an HTML template 

1. Select any template from the Template list. 

2. Select Export > “HTML”.  

3. Specify the desired name and the destination folder where your HTML template is to be created. 

Alternatively, you can compress the template folder to .zip format using "Export as a ZIP archive" 

option. 

The resulting template will contain markup, styles and graphics that are necessary to apply the design to 

any Web page.  

Exporting a design as an ASP.NET Project 

To export a design as an ASP.NET project that can be later opened in Visual Studio, you should take the 

following steps: 

1. Select Template > ASP.NET Application option. 

2. Use Export > "Visual Studio C# Project". 

3. Specify the template name and select the folder to store the template files.  If necessary, apply zip 

compression using "Export as a ZIP archive" option. 

When the export is completed, a new C# project will be created in the specified location.  Open it in Visual 

Studio using File > Open Website option and examine the files created. You will see: 

 Master Page that defines a site's overall layout and contains a set of content placeholders such as 

HeaderContentPlaceHolder, TitleContentPlaceHolder, SheetContentPlaceHolder etc.  

 Content Page called Default.aspx that has several content blocks and default pages 

(DefaultHeader, DefaultMenu, DefaultSidebar1) included into it. This page is generated as an 

example for you to see how a finished content page may look like.  

 CSS files that define the design of the pages. 

 A set of other files necessary for the Visual Studio project. 

http://drupal.org/node/133977
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Feel free to modify the project files the way you want and enjoy! 

Exporting a design as a CodeCharge Studio Project 

To create a design that can be applied to CodeCharge Studio projects the following steps should be 

performed: 

 Select Template->CodeCharge Studio template. 

 Select Export Design ->"CodeCharge Studio Project" option. 

 Browse to the folder where you want to locate the CCS project and click Ok to export the files. 

When the export is completed, a new CodeCharge Studio project will be created in the specified location. 

The following pages will be added to the project: 

 PageTemplate 

 Header 

 Footer   

 Main 

 About 

PageTemplate is an essential page that will be used as a basis for creating all the new pages within the 

CCS project. This functionality is achieved using Project Settings->General->New Page Template option. 

PageTemplate includes the Header and Footer pages that are used to add page background, sheet, header 

and menu styles to the pages. Thus all the newly created CCS pages will have page background, sheet, 

header and menu styles automatically applied to them.  

However the Artisteer-generated styles cannot be automatically applied to CCS forms, buttons, and other 

blocks on the page. 

To add style to these components you can consider one of the following solutions: 

 Open CCS Style Builder (Tools >Styles) and add a new style that looks similar to the style 

generated by Artisteer. Use this new style for CCS forms and controls. 

 Modify a CCS page template to add the Artisteer styles manually. In that case, do not select any 

style when creating forms and controls in CCS. Then switch to HTML mode and modify your page 



28 

page 

 

 artisteer.com | page 28  

template manually adding the Artisteer classes and the necessary html tags. A sample html code is 

provided on the Main page so you can review it and modify CCS page templates accordingly.  

The example code below demonstrates how to apply the Artisteer-generated styles to a Record form on 

CCS page. The unchanged HTML code is shown in black, the removed code lines are crossed out and 

highlighted in red, and the lines added to the code are highlighted in blue color. 
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2. Colors & Fonts 

The Color & Fonts tab provides the ability to change the colors and fonts of the template. 

 

2.1. Colors  

To change the site theme select a Theme from a variety of available color themes. Further the individual 

colors can be changed. Having chosen the Colors, you may refine colors by adjusting the overall contrast of 

the colors. 

2.2. Paints  

In this block you have the ability to adjust the Color theme. Select one of the predefined schemes or 

customize the color theme selecting the desired colors. 

 

Clicking on the “Adjust options…” will open the list of the available color options: 

 Luminosity 

 Saturation 
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 Enter the values or drag the sliders to the right to increase option values or to the left to decrease them.  

 

Properties: 

Adjust Color Options 

 

Luminosity 

Sets colors luminosity. Luminosity refers to the whiteness or intensity of a 

color. Luminosity for any one color will range from pure white though to black. 

The supported values are from -100% to 100%.Where 100% and -100% refer 

to the highest and lowest of the RGB components. 

 

Saturation 

Sets color saturation. Saturation refers to the amount of grey in a color, and 

determines how vivid it is. 

The supported values are from -100% to 100%.Where 100% means a large 

amount of the grey.  

2.3 Fonts 

Select from a wide variety of font themes to match the overall look and content of the site. 

 

The Fonts section includes the following functions: 

 Font Sets 
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 Typography 

 Font Scale 

Font Sets allows you to change the text and heading fonts. You can choose one of our standard font sets 

or create your own font scheme. Just click on the Edit Font Set… button in the Font Sets list. 

Typography option allows you to select one of our typography styles or create your own style design. Just 

click on the Edit Typography… button in the Typography list.  

 

In the opened Typography dialog you can change any text object by selecting the object and clicking the 

"Modify" button. The Modify dialog allows adjusting the following Font settings: 

 Font Family 

 Font Style 

 Font Size (in pixels) 

 Add or remove Effects 

 Adjust Character Spacing 
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For the Footer Text, Blocks Text, Article Headline Text and Article Header Text you can also modify 

Paragraph settings such as: 

 Alignment 

 Indentation 

 Spacing 
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Font Scale option allows you to change the overall font scale. You can set custom the Font Scale. Just 

click on the Options… button. 

           

Properties: 
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Typography options 

 

Font Scale 

Sets Font scale for all text. The supported values are from 50% to 200%. 

Where 200% means the biggest font scale.  

3. Layout 

The layout tab is where you can quickly change the overall positioning of elements on the page. 

 

3.1 Page/Column Layout 

You can quickly change the positioning of the header and navigator bars. Place the navigator above or 

below the header or choose not to use a menu bar at all. In addition, if your page will have more content, 

you might want to expand your site into two or more columns. 
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3.2 Columns 

When a multi-column layout is being used, the Layout Options dialog displays a set of sliders that that 

allows you to set the percentage widths of the columns.  

 

Clicking on the "Width Options…" will open the Layout Options Dialog. You can enter the values to achieve 

the desired column width. 

 

4. Background 

The background of the page is just as important as the page itself.  Change the background effects to 

achieve the desired look.   
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You can choose to have: 

 Background image. Select one of our images or insert your own (click the  

button). 

 Image or Texture. You can insert your own texture template. 

 Glare. You can also insert your own Glare template. 

 Gradient. 

 Overall color of the Background. 

4.1 Adjust Page Background options. 

Open "Options…" dialog to improve the design of the page background. You can customize:  

 Image or Texture 

 Glare 

 Gradient 
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Properties:  

Image or Texture 

 

Texture Repeat 

Sets if/how a background image or texture will be repeated. 

The supported values: 

 Fill - The background image will be repeated vertically and horizontally 

 Horizontally (Default) - The background image will be repeated horizontally 

 Vertically - The background image will be repeated vertically 

 No repeat - The background-image will be displayed only once.This option 

is not available when”No Texture” is selected in “Image or Texture” list. 

 

Position 

Sets the starting position of a background image. 

This option is not available when”No Texture” is selected in “Image or Texture” list.  

 

Scrolling 

Sets whether a background image is fixed or scrolls with the rest of the page. 

This option is not available when”No Texture” is selected in “Image or Texture” list. 

 

Transparency 

Sets background texture image transparency. 

The supported values are from 0 to 100%, where 0% means “without 

transparency». This option is not available when”No Texture” is selected in “Image 

or Texture” list. 

 

 

Blend Mode 

Sets how background color and background texture image layers are blended into 

each other. 

There are 3 options available: 

 Normal - No effect on the underlying layers. 

 Overlay - Blends the two layers together by changing the opacity, darkness, 

and lightness of the top layer. 

 Soft Light - This blend mode lightens or darkens the image depending on 

the color of the top layer: if the top layer's pixel is dark, then the bottom 

layer's pixel is darkened; if the top layer's pixel is light, then the bottom 
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layer's pixel is lightened. 

This option is not available when”No Texture” is selected in the "Image or Texture" 

list. 

 

Glare 

 

Transparency 

Sets glare transparency for the Page background. The supported values are from 

0% to 100% where 0% means "without transparency". 

This option is not available if “No Glare” is selected in the Glare list. 

 

Align 

Sets the position of a glare image. Available options are Left and Center to align 

the glare image left, center or right respectively. 

This option is not available if "No Glare" is selected in the Glare list. 

 

Gradient 

 

Height 

Sets height for the selected gradient type (the gradient type may be changed in 

Gradient list). 

The supported values are from 1 to 1000 pixels. 

This option is not available when "No Gradient" is selected in the Gradient list. 

 

Contrast 

Increases or decreases luminosity difference between the starting and ending 

colors in the gradient. 

This option is not available when”No Gradient” is selected in the Gradient list. 

5. Sheet 

The Sheet tab provides the ability to change the overall positioning and look of the sheet or page. You 

might prefer a sheet with rounded edges instead of square edges. Or you may want to move the sheet 
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down a bit from the top of the page, put a shadow effect or change the width of the borders or the sheet’s 

background transparency or the color of the sheet. 

 

5.1 Adjust Sheet options 

The sheet options can be customized by clicking on the appropriate button in the option list. For example, if 

you want to change Padding value click on the More Padding… button. 

 

When you open the "Sheet Options" dialog you will be able to edit the design of the sheet. Play around with 

the Sheet & Shadow parameters to achieve the desired result. 
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Sheet parameters include the width of the sheet and its borders, the padding and the radius values. Also 

you can set custom transparency values for the sheet background. Shadow parameters control the size, 

angle and opacity of the shadow as well as its distance from the sheet borders.  Enter the values or drag 

the sliders to the right to increase option values or to the left to decrease them. 

 

Properties: 

Sheet 

 

Width 

Sets the Sheet width in pixels. Supported values: 500 px (the minimum width) –

1500 px (the maximum sheet width).  

 

Top offset 

Sets the Top Offset for the sheet in pixels. Supported values: 0 px – 200 px, where 

0 px means "no top offset". 

This option is reset to 0 if “Without Offset” option is selected in the Top Offset list. 

 

Padding 

Sets the padding for the sheet content in pixels. Supported values: 0 px to 50 px, 

where 0 px means no padding.  

This option is disabled when “No Padding” is selected in the Padding list. 

 

Radius 

Sets the corner radius of the sheet in pixels. Supported values: 0 px – 200 px, 

where 0 px is equivalent to “No Radius” selected in the Radius list. 

 

Border Width 

Sets border width for the sheet in pixels. Supported values are: 0 px – 20 px, where 

0 px is equivalent to “No Border” in the Border list. 

 

Transparency 

Sets the sheet transparency. Supported values are: 0% to 100%, where 0% is 

equivalent to “No transparency” selected in the Transparency list. 
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Shadow 

 

Size 

Sets the shadow size for the sheet’s shadow in pixels. Supported values are from 0 

px to 50 px, where 0 px means “without shadow”. 

This option is disabled when “No Shadow” is selected in the Shadow list. 

 

Opacity 

Sets the opacity for the sheet’s shadow. Supported values range from 0% (fully 

transparent) to 100% (fully opaque). 

This option is disabled when “No Shadow” is selected in the Shadow list. 

 

Distance 

Sets the shadow offset in pixels. Supported values: 0 px – 60 px, where 0 means 

"no offset". 

This option is disabled when “No Shadow” is selected in the Shadow list. 

 

Angle 

Sets the shadow’s offset direction. 

The supported values are from -180° to 180°. 

This option is disabled when “No Shadow” is selected in the Shadow list. 

 

6. Header 

The header tab controls all aspects of the header, including the size, colors, fonts, foreground and 

background images.  Make changes to the size and look of the header while being able to include 

background and foreground images. 
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6.1 Header Layout 

You can make changes to the header layout such as: 

 Header Size 

 Text Block. Here you can choose a Text block position and width. 

Both layout options can be configured in the General tab of the "Header Options" dialog: 

 

Properties: 

Define the basic properties of the Header.  

Note: the Header Options have no effect on layouts without header selected in Layout > Page Layout list. 

General 

  

Height 

Sets the height of the header in pixels. The value can range from 50 to 

500 px. 

 

Text Block 

Sets the width of the text block as a percentage of the header width. 

Range goes from 0% (no text block) to 100% (text block covers the 

entire header). 

6.2 Background 

6.2.1. Background image 

Choose from a wide variety of professional background images to be used in the header of your site: 

 Abstract 
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 City 

 Landscape 

 Nature 

 Clouds 

Also you can insert you own background image. Click the From File… button in the Background Photo list 

and select the image you want to use. 

6.2.2. Background Image position 

Feel free to change the position of the picture. Also Position dialog allows you to apply the following Header 

Image settings: 

 Resize header to image  

 Resize image to header 

 Use the original image size. 

 

The background parameters can be manually adjusted in the second tab of the "Header Options" dialog. 
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Properties: 

Define the Basic Settings of the Header Background. Depending on the selected image, some background 

options may be disabled. 

Background 

 

 

Color Weight 

 

Sets the amount of the Base Color applied to the header image. The 

Base Color for the header is selected under Background > Effects > 

Color. 

Supported values are from 0% to 100%. 

 

 

Color Saturation 

 

Specify the Base Color Intensity The values range from 0 (completely 

desaturated, grey) to 100% (completely saturated, full color intensity). 

Supported values are from 0% to 100%. 

 

 

Blur 

Sets the blur radius ranging from 0 to 30 pixels. The Blur effect 

averages all pixels within the specified radius; the larger radius leads to 

more blurring. 

 

 

Blend Mode 

(Enabled only for 'Abstract' 

backgrounds) 

 

Sets how the header image is blended with the header color. This option 

is enabled only for the 'Abstract' background images. 

Supported values are: 

Softlight – Lightens or darkens the bottom layer colors depending on the 

colors of the Header Image.  

Overlay – Blends two layers preserving the opacity, lightness and 

darkness of the bottom layer. 

 

 

Sets a quality level for JPEG compression. The range goes from 0 to 

100%. Better image quality results in larger file size so drag the slider 

left or right to select an appropriate trade-off between file size and 
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JPEG Quality image quality. 

6.2.3. Background Image Effects 

You can add visual Effects to the background to make your design look even more impressive and unique. 

Header Background Options include the following effects that can be applied to the header Background: 

 Color of the header. If you select “No photo” in the Background photo list the Header will be 

filled with the chosen color.  If you select the background image, this color will be used for 

image colorization. 

 Image Recolor. 

 Glare. You can insert your own glare template. 

 Texture. You can also insert your own texture template. 

 Gradient. 

 Blur. 

 

Properties: 

Effects 

Glare 
Specify the Glare Settings for the Header Background. To enable select 

any Glare from Header Background > Effects > Glare. 

 

Transparency 

Specify the transparency of the Glare image. Supported values: 0% (no 

transparency) - 100% (fully transparent). 
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Blend Mode 

Specify how the Glare blends with the underlying layer of the block.  

Options:  

Normal - No effect on the underlying layers. 

Soft Light - Lightens or darkens the image depending on the color of the 

Glare Image. 

Overlay - Blends the layers together by changing the opacity, darkness, 

and lightness of the Glare Image. 

 

Position 

Specify the position of a Glare Image.  

Supported values: Left, Center and Right. 

 

Fit 

Specify the method of fitting the image into the Header area.  

Options: 

              · Vertical - resizes the image’s height so that it fits vertically 

into the header area. 

             · Whole - resizes the image both vertically and horizontally to fit 

completely into the header (occupy the entire header area). 

Gradient 
Specify the gradient settings for the header area. To enable select any 

Gradient from Header > Background > Effects > Gradient. 

 

 

Contrast 

Specify the contrast between the starting and ending colors in the 

gradient. The values range from -100 (solid color) to 100% (the most 

gradient contrast). 

 

Angle 

Specifies the angle at which the gradient is applied. The values range 

from -180˚ to 180˚ which allows you to select any desired direction of 

the gradient fill. 

Texture 
Specify the Glow of the foreground object. To enable use a Foreground 

Photo on the header. 

 

Transparency 

Specify the transparency of the header texture. Supported values: 0% 

(no transparency) - 100% (fully transparent). 
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Blend mode 

Specify how the texture blends with the underlying layers of the header.  

Options: 

                 · Normal - No effect on the underlying layers. 

                 · Soft Light - Lightens or darkens the image depending on the 

color of the Texture Image. 

                 · Overlay - Blends the layers together by changing the 

opacity, darkness, and lightness of the Texture Image. 

6.3. Foreground Photo 

This section provides the ability to add a photo that will be complementing your Header. You have the ability 

to choose the Foreground Photo from a variety of professional photos or many different types of subjects. 

You can also insert your own photo. 

6.3.1. Position 

Feel free to change the position of the foreground photo in the Object Position dialog. Simply drag the photo 

to the necessary place. Also this dialog allows you to change the size of the photo. Just move the slider or 

click on the “100%” button to apply full size of the photo. 
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6.3.2. Effects 

You can add visual Effects to the Foreground Photo to make your design look even more impressive and 

unique. Header Foreground Photo Options include the following effects that can be applied to the Header 

Foreground Photo: 

 Recolor 

 Glow 

 Flip 

The Foreground Photo effects can be manually adjusted on the fourth tab of the "Header Options" dialog. 

 

Properties: 

Specify the Glow of the foreground object. To enable use a Foreground Photo for the header. 

6.4. Title 

This section provides the ability to change Headline Text and Slogan Text of your design.  

Foreground Photo 

 

Glow Size 

Specify the size of the Glow from edges of the foreground object.  

 

Glow Opacity 

Specify the Glow intensity. Supported values: 0% (fully transparent, invisible) 

– 100% (solid, opaque glow). 
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Also you can specify the necessary Font Options: 

 Color 

 Font Family 

 Font Style 

 Font Size 

 

Clicking the “Font Options…” button opens the Header Logo Name/Slogan dialog where you can adjust the 

Font Settings like: 

 Font Family 

 Font Style 

 Font Size (in pixels) 

 Effects 

 Character Spacing 
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6.5. Title Style 

This section provides the ability to change Title Style settings to complete your Title.  

The Title Style section includes the following functions: 

 Position. Simply drag the Title to the desired place: 

 

 Size 

 Align 
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7. Menu 

The Menu tab is used to control the position and appearance of the main navigation menu. It consists of the 

menu bar and the menu items.  It can be implemented as a standard website menu or in the form of tabs or 

menu buttons. 

 

7.1. Menu Styles. 

Change the overall style of the menu buttons including the shape, coloring, borders and spacing between 

the items. 

Using the Styling Option you can change the following settings: 

 Shape 

 Margin 

 Distance 

 Separator 

There are Margin and Distance options available for adjustments to the menu layout: 
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Properties: 

7.2. Menu bar 

Refine the navigation bar further by choosing the overall gradient, border width, color and fill effect. 

 

“Menu Options” dialog allows you to adjust Gradient and Border settings. Just click on the “Gradient 

Options…” or “More Borders…” button in the appropriate list. 

 

Layout 

 

Margin 

Specify the space around the menu. Supported values: 0 – 20 pixels. 

Please note for the Tabbed Menu the top margins look doubled, as the menu 

is bottom-aligned.  

 

Distance 

Specify the horizontal distance between Menu Items. Supported values: 0 – 

30 pixels. 



54 

page 

 

 artisteer.com | page 54  

Properties: 

7.3. Item 

This section provides the ability to choose how individual items of the navigation bar should look when you 

hover over or click on them.  

 

This section includes the following functions: 

 Set the Size, Radius and Gradient values fro the menu Items by clicking on the “Item” 

button. 

 Adjust Border settings. 

 Change color and text parameters. 

If the default settings don't meet your needs, use the "Menu Options" dialog to adjust the option settings. 

Menu Bar 

 

Border width 

Specify the Width of the Menu Borders. Supported values: 0 – 5 pixels.  

To enable select any border for the Menu Bar. 

 

 

 

Gradient contrast 

Specify the contrast between the starting and ending colors in the menu bar 

gradient. Supported values: -100 (solid color) to 100% (the most contrast 

gradient). 

To enable select any Gradient from the Menu > Menu Bar > Menu Bar > 

Gradient list.  
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Properties: 

7.4. Subitem 

This section provides the ability to control the appearance of items in submenus.  

You can change the following options: 

 Gradient and Size in the subitem list 

Item 

 

Horizontal padding 

Specify the horizontal distance between the Item Text and Item Borders. 

Supported values: 0 – 50 pixels. 

 

Vertical padding 

Specify the top and bottom padding of the Menu Items. Supported values: 0 – 

50 pixels. 

 

Radius 

Specify the Corner Radius of the Menu Item. Supported values: 0 - 100%.  

 

Border width 

Specify the Width of the Menu Item Borders. Supported values: 0 – 5 pixels.  

This option is disabled when the Menu Items have no borders. 

 

 

Gradient contrast 

Specify the contrast between the starting and ending colors in the item 

gradient. Supported values: -100 (solid color) to 100% (the most contrast 

gradient). 

To enable select any Gradient from the Menu > Item > Item > Gradient list.  
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 Fill 

 Border 

 Text 

If the default settings don't meet your needs, use the "Menu Options" dialog to adjust the option settings. 

 

Properties: 

Specify the submenu options.  

Please note: The options are disabled if “No Submenus” is selected in the Subitem list > Level. Also please 

note that the Gradient contrast option is disabled if “No gradient” is selected in the Subitem list > Gradient. 
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8. Articles 

The Article tab provides the ability to control the look of the Article. You can choose the Blockless or in-

Block article shape, format the Text option, change the Article header and Footer.  

 

8.1. Shape 

In this section you can choose the Article Content Shape (Blockless or in-Block) and using the Styling 

button to change the following style options: 

 Content 

o Margin 

Subitem 

 

Horizontal padding 

Specify the horizontal distance in the Subitem drop-down list, in pixels. 

Supported values: 0 – 50 pixels. 

 

Vertical padding 

Specifies the top and bottom padding of the Menu Subitems. Supported 

values: 0 – 50 pixels. 

 

Border width 

Specify the width of the Subitem Borders. Supported values: 0 – 5 pixels.  

 

Gradient contrast 

Specify the contrast between the starting and ending colors in the Subitem 

Gradient. Supported values: -100 (solid color) to 100% (the most contrast 

gradient). 

To enable select any Gradient from the Menu > Subitem > Subitem > Gradient 

list. 
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o Text Padding 

 Shape 

o Fill 

o Border 

o Radius 

 Effects 

o Shadow 

 

8.1.1. Shape 

If the default settings do not meet your requirements, you can use the "Articles Options" dialog to customize 

the settings. To get to the required Section of the Article Options click on the “More..” button, for example 

“More Paddings…”, below any list. 

 

Properties: 

Shape 

 

Margin 

Specify the Margin of the Article content in pixels. Supported values 

are: 0 – 50 pixels. 

 

Padding 

Specify Padding of the Article text in pixels. Supported values: 0 – 50 

pixels. 

 Specify the Corner Radius of the in-block content in pixels. Supported 
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Radius values: 0 to 40 pixels. 

 

Border  

Width(Available if  

In-Block Shape 

 is used) 

Specify the Border Width of the in-block content in pixels. Supported 

values: 0 to 10 pixels. 0 corresponds to “Without Border”. 

8.1.2. Shadow 

Clicking on the “More Shadows…” button in the styling > Shadow list opens the “Article Options” dialog 

where you can adjust shadow options. 

 

Properties: 

Please note:  The Shadow Options are available only for the In-Block Shape. 

Shadow 

 

Size 

Specify the Shadow Size of the Article block in pixels. Supported 

values: 0 – 20 pixels. 

 

Opacity 

Specify the Shadow Opacity of the Article Block. Supported values 

are: 0 to 100%. 

 

Distance 

Specify the Offset Distance of the shadow in pixels. Supported values: 

0 – 20 pixels, where 0 indicates no offset. 

 

Angle 

Specify the Angle at which the shadow is dropped from the Article 

Block. Supported values: -180º to 180 º. 
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8.2. Text Formatting 

This section allows you to change the Text format options like: 

 Margin Left 

 Margin Right 

 Line Height 

 Character Spaying 

 Font Options 

 Align 

 

Clicking on the “Font Options…” button opens the Article Content-Text option dialog where you can adjust 

such Font Settings like: 

 Font Family 

 Font Style 

 Font Size (in pixels) 

 Effects 

 Character Spacing 
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You can also modify the Paragraph setting including:  

 Alignment 

 Indentation 

 Spacing 

Just click on the “More options…” button in the appropriate Text formatting list. 
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8.3. Other elements 

This section provides the ability to control the look of the following article elements: 

 Headings 

 Hyperlink 

 Quote 

 Bullets 

 Picture 

 Table 

 

You can change the Font options, Quote Style, Bullets picture, Table border settings or Picture Border 

settings to make your Article more unique.  
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Clicking on the “Font Options…” button in the appropriate element list (Headings, Hyperlink, and Quote) will 

open the Article Content Option dialog window where you can adjust Font and Paragraph (for Headings and 

Quote) settings. 

It's worth mentioning the Bullets elements. You can choose a Picture from the variety of included images 

or insert your custom image. You can also change the color of the bullet. 

 

Clicking on the “Bullet Option…” button will open the Article Option Dialog where you can change the Offset 

and Recoloring options of the Bullets. 
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Properties: 

To finish your List configuration you can change the Font options of the Text in the List. Just click on the 

“Font Option…” button and adjust the Font and Paragraph settings in the Articles Content – List dialog. 

 

8.4. Header and Footer 

You can customize the Article Header and Footer: adjust Style, Text and Headline by choosing icons from 

the predefined pictures or using your own images.  

Bullets 

 

Offset 

Specify the indent between the Bullet and the List Text. Supported values: 0 – 

20 pixels. 

 

Recoloring 

Specifies whether the bullets should be re-colored.  

Supported values: Yes and No. 



65 

page 

 

 artisteer.com | page 65  

 

You can change the Date, Author and Edit icons located in the Article Header section, and the Category, 

Tags and Comments icons located in the Article’s Footer. 

 

9. Blocks 

Blocks are the individual components that make up the content of the page.  Things located in the blocks 

include links, bookmarks, search and the overall postings of the page. 
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9.1. Block Styles. 

Chose how you want blocks to be contained.  Maybe you want the content underneath a block to fall within 

a border.  

9.1.1. Styling 

Styling option provides the ability to change block spacing, alter the distance between blocks, or make the 

blocks more rounded by changing the radius value. 

 

Clicking on the “More….” buttons in Styling lists will open the Block Option dialog where you can adjust 

layout options. 
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Properties: 

9.1.2. Background 

If your template allows it, you can change the background color and border of the blocks, as well as apply 

different Effects to your blocks. 

 

Clicking on the “More……” buttons will open a Block options dialog: 

Layout 

 

Radius 

Specify the Radius of Block Corners. Supported values: 0 to 40 pixels. To 

enable select any blocked style from the "Block Styles" list. 

 

Block spacing 

Specifies the Spacing around blocks in pixels. Supported values: 0 – 40 

pixels. 

 

Distance 

Specify the vertical distance between the Header and Body sections of the 

Block. To enable select any blocked style from the "Block Styles" list. 
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Properties: 

 

If you selected a template with a shadow effect, the Shadow option provides the ability to change size, 

angle and opacity of the block shadow as well as indicate the distance between the shadow and the block 

borders. 

Just click on the “More Shadow…” button in the Background -> Effects -> Shadow list. 

Background 

 

Padding 

Specify the space between the outer borders of the Block and the content 

area within the Block. Supported values: 0 – 50 pixels. To enable select any 

blocked style from the "Block Styles" list. 

 

Border width 

Specify the Block Border width. Supported values: 0 – 10 pixels. To enable 

select any blocked style from the "Block Styles" list. 

 

 

Gradient contrast 

Specify the luminance difference between the starting and ending colors of the 

gradient. Supported values: -100 (solid color) to 100% (the most contrast 

gradient). 

To enable select any Gradient from Blocks > Block Styles > Background > 

Gradient list. 

Texture 
Specify the Background Texture options. To enable select any Texture from 

Blocks > Block Styles > Background > Texture list. 

 

Transparency 

Specify the Transparency of the Background Texture. Supported values: 0 

(fully opaque) – 100% (fully invisible). 

 

 

Blend mode 

Specify how the Texture blends with the underlying layer of the block.  

Options: 

        · Normal - No effect on the underlying layers. 

        · Soft Light - Lightens or darkens the image depending on the color of the 

Texture Image. 

        · Overlay - Blends the layers together by changing the opacity, darkness, 

and lightness of the Texture Image. 
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Properties: 

Specify the shadow options. The options are disabled for no-block styles selected in the "Block Styles" list. 

9.1.3. Header 

Each block has an individual header.  Chose how you want that header to look like.  You can change the 

header color as well as the font and color of the text. Also, you can choose an icon from a variety of 

proposed icons or insert your custom icon image.  

Shadow 

 

Size 

Specify the Shadow Fussiness. Supported values: 0 – 20 pixels. 

 

Opacity 

Specify the Shadow Opacity. Supported values: 0 (fully transparent) – 100% 

(fully opaque). 

 

Distance 

Specify the Shadow Offset in pixels. Supported values: 0 – 20 pixels.  

 

Angle 

Specify the Shadow Angle starting from edges of the block. Supported values: 

-180° to 180°. 
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You can add Gradient and Texture Effects to the Block header. Both options can be further customized in 

the Block Options dialog.  

You can also add a custom Texture to the block header. 

 

Clicking on the “Texture Options…” or “Gradient Options…” in the appropriate list will open the Block Option 

dialog where you can adjust Effects settings. 



72 

page 

 

 artisteer.com | page 72  

 

Properties: 

Header 

 

Border width 

Specify the Width of the Block Header Border. Supported values: 0 – 10 

pixels.  

To enable select any with-header style from the "Block Styles" list. 

 

Gradient contrast 

Specify the contrast between the starting and ending colors in the gradient. 

Supported values: -100 (solid color) to 100% (the most contrast gradient). 

To enable select any Gradient from Blocks > Block Styles > Header > 

Gradient list. 

Texture 
Specify the settings of the Block Header Texture. To enable select any 

Texture from Blocks > Block Styles > Header > Texture list. 

 

Transparency 

Specify the Transparency of the Block Header Texture. Supported values 0 

(fully opaque) to 100% (fully transparent). 

 

Blend mode 

Specify how the Texture blends with the underlying layer of the block.  

Supported values: 

Normal - No effect on the underlying layers. 

Soft Light - Lightens or darkens the image depending on the color of the 

Texture Image. 

Overlay - Blends the layers together by changing the opacity, darkness, and 

lightness of the Texture Image. 
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9.1.3. Content 

You can adjust the color and style of the block content as well as control the borders, text colors and 

hyperlinks that appear in the blocks. 

 

You can also add gradient and Texture Effect to the Block’s Content. Both options are available for 

customization. You can also add custom Texture template. 

Clicking on the “Texture Options…” or “Gradient Options…” in the appropriate lists will open the Block 

Option dialog where you can adjust Effects and Bullets settings. 
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Properties: 

Content 

 

Padding 

Specify the space between the Content Block Borders and the content of the 

block. Supported values: 0 – 50 pixels. 

 

 

Border width 

Specify the width of the Content Block Borders. Supported values: 0 – 10 

pixels.  

To enable select any style with inner Content Block from the "Block Styles" 

list. 

 

 

Gradient contrast 

Specify the difference in luminance between the starting and ending colors in 

the gradient. Supported values: -100 (solid color) to 100% (the most contrast 

gradient). 

To enable select any Gradient from the Blocks > Block Styles > Content > 

Gradient list. 

Texture  Specify the settings of the Block Header Texture. To enable select any 

Texture from Blocks > Block Styles > Content > Texture list. 

 

Transparency 

Specify the Transparency of the Content Block Texture. Supported values 0 

(fully opaque) to 100% (fully transparent). 

 

 

Blend mode 

Specify how the Texture blends with the underlying layer of the block.  

Supported values: 

Normal - No effect on the underlying layers. 

Soft Light - Lightens or darkens the image depending on the color of the 

Texture Image. 

Overlay - Blends the layers together by changing the opacity, darkness, and 

lightness of the Texture Image. 

Bullets Specify the Bullet Properties. 

 

Offset 

Specify the indent between the Bullet and the List Text. Supported values: 0 – 

20 pixels. 

 

Recoloring 

Specifies whether the bullets should be re-colored.  
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9.2. Block Content 

This section allows you to change the settings like: 

 

 Margin Left 

 Margin Right 

 Line Height 

 Character Spaying 

 Font Options 

 Link Options 

 Bullets 

You can also modify the Font settings of the Block Content according to your needs. 

 

Clicking on the “Font Options…” button will open the Article Content-Text options dialog where you can 

adjust such Font Settings like: 

 Font Family 

 Font Style 

 Font Size (in pixels) 

 Effects 
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 Character Spacing 

 

And the Paragraph settings like:  

 Alignment 

 Indentation 

 Spacing 

Just click on the “More options…” button in the appropriate Text formatting list. 
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Also you can modify Link parameters, Visited and Hovered Link Font settings: 

 

Just click on the “Font options…” button in the appropriate Link list. 

To complement your Block you can change Bullets parameters. 
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10. Buttons 

The Buttons tab is used to choose the shape and style of the Buttons. 

 

Button Styles 

Select from a wide variety of button styles.  You can choose buttons with more rounded corners, something 

in between, or completely rectangular shape. 

 

Button Format 

Make your finishing touches to the button.  

 

The Button section allows you to change the following options: 

 Shape 

 Gradient 

 Border 

 Shadow 

 Fill Color 
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 Border Color 

 Text 

Artisteer provides a variety of Button’s shape templates. Clicking on the “Shape Option…” button in the 

shape List you can adjust the shape settings. Also you can adjust some Effects like Gradient contrast: 

 

 Properties: 

 

If you add a Shadow Effect to your Buttons you have the possibility to make custom changes in the Button 

Option dialog. Just click on the “Shadow options…” button. 

Button 

 

Horizontal padding 

Specify the horizontal distance between the Button Caption and Button 

Borders. Supported values: 0 – 50 pixels. 

 

Vertical padding 

Specify the vertical distance between the Button Caption and Button Borders. 

Supported values: 0 – 50 pixels. 

 

Radius 

Specify the Button Corners. Supported values: 0 – 100%.  

 

Border width 

Specify the Width of the Button Borders. Supported values: 0 – 10 pixels.  

 

 

Gradient contrast 

Specify the Contrast between the starting and ending colors in the button 

gradient. Supported values: -100 (solid color) to 100% (the most contrast 

gradient). 

To enable select any Gradient from the Buttons > Button > Gradient list. 
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Properties: 

 

To finish the Button design you can change the overall Fill of the Buttons or change the Text settings. The 

Text option allows to you to change the color of Buttons and Hovered Buttons as well as adjust Font 

settings. 

 

Shadow 

 

Size 

Specify the Blur Size of the shadow. Supported values: 0 – 20 pixels. 

 

Opacity 

Specify the Shadow Opacity. Supported values: 0 (fully transparent) to 100% 

(fully opaque). 

 

Distance 

Specifies the Shadow Offset in pixels. Supported values: 0 – 20 pixels.  

 

Angle 

Specify the Angle at which the shadow is cast from the button. Supported 

values: -180° to 180°. 
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11. Footer Tab 

The Footer tab is used to specify the style of the website’s footer. 

 

11.1 Footer Styles 

Footers Options include the following effects that can be applied to the Footer: 

 Color 

 Gradient 

 Texture 

 Align 

 Text Padding 

 Text font 

 Change Hyperlinks font 

 RSS icon  

In the Footer Options dialog you can customize effects applied to the Footer. 
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Properties: 

Options 

 

Padding 

Specify the padding of the Footer’s text in pixels.  Supported values: 0 – 

50 pixels, where 0 means “No Padding”. 

 

Gradient Contrast 

(Available if a Gradient  

is used ) 

Use to increase or decrease the luminosity difference between the starting 

and ending color of the gradient. 

 

Texture Transparency 

(Available if a Texture 

 is used )  

Specify the Texture Transparency. The supported values are from 0 (fully 

opaque) to 100% (fully transparent, invisible texture).  

 

Texture Blend Mode 

(Available if a Texture 

 is used ) 

Specify the Blend Mode applied while mixing the background color and 

texture image: 

Normal - No effect is applied while mixing layers; 

Overlay - Two layers are blended by changing the opacity, darkness, and 

lightness of the Texture. 

Soft Light – Changes the colors in the Footer image depending on the 

color of the top layer. 
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Troubleshooting 

".NET Framework is not installed" error. 

Artisteer requires .NET Framework 2.0 or higher to be installed on your computer.  

Solution 

Microsoft NET Framework can be obtained and installed from: 

http://www.microsoft.com/downloads/details.aspx?familyid=79BC3B77-E02C-4AD3-AACF-

A7633F706BA5&displaylang=en 

 

PHP Fatal error in WordPress  

PHP Fatal error: Only variables can be passed by reference in ...\wordpress\wp-includes\query.php on line 

2548 

Occurs when the posts page is set to a static page different from the homepage: 

Solution 

Upgrade your PHP version or use the following workaround: 

Open the query.php and replace the code line 

$this->queried_object = & get_page(get_option('page_for_posts')); 

with the two lines 

$tmpPageVariable = get_option('page_for_posts'); 

$this->queried_object = & get_page($tmpPageVariable); 

http://www.microsoft.com/downloads/details.aspx?familyid=79BC3B77-E02C-4AD3-AACF-A7633F706BA5&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=79BC3B77-E02C-4AD3-AACF-A7633F706BA5&displaylang=en
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Glossary 

CMS  

A Content Management System (CMS) is a software application designed to create, edit, publish and 

manage Website content using a simple browser-based interface. The content may include text, photos, 

electronic documents, music, video and other type of computer files. 

CMSs usually provide a number of ready-made solutions and standard templates for most common 

applications.  

The main advantage of CMS is that it requires almost no technical skills or knowledge to create the website 

and manage its content. 

Blog 

A blog (short for "Web log") is a special type of Web site with a series of entries usually posted to a single 

page in reverse-chronological order. 

Blogs are often maintained by an individual and represent the personality of the author, provide diary-type 

commentary, links to articles on other Web sites, descriptions of different events and social issues, or 

include other material such as graphics or video.  

WordPress 

WordPress is an open source blog publishing application, an advanced blogging tool with a focus on 

aesthetics, web standards, and usability. The official WordPress website is http://wordpress.org. 

Joomla 

Joomla is a free open source content management system written in PHP. It is used for publishing and 

managing content on the web and intranets and allows you to build powerful online applications.  

The official Joomla website is http://www.joomla.org. 

http://wordpress.org/
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Drupal 

Drupal is a free software package that allows an individual or a community of users to easily publish, 

manage and organize a wide variety of content on a website. It is an open-source project written in PHP 

and distributed under the GPL. The official Drupal website is http://drupal.org. 

Visual Studio 

Visual Studio is an integrated development environment (IDE) from Microsoft company. The official website 

is http://www.microsoft.com/visualstudio/en-us/default.mspx. 

CodeCharge Studio 

CodeCharge Studio(CCS) is a Rapid Web Application Development Tool from YesSoftware company. It is a 

software for visually creating dynamic database-driven Web applications. The official company website is 

http://www.yessoftware.com. 

HTML 

HyperText Markup Language (HTML) is the predominant markup language for Web pages which provides a 

set of markup symbols or codes to specify the structure of documents for retrieval across the Internet using 

Web browser programs. HTML is written in the form of tags, surrounded by angle brackets. The document 

can contain links, headings, paragraphs, lists, and text supplemented with interactive forms, embedded 

images, and other objects.  

CSS 

Cascading Style Sheets (CSS) is a style language that defines the presentation of a document written in a 

markup language.  CSS controls the overall layout, text size, style, and formatting and other design 

properties to let developers separate content from design. 

RGB 

RGB stands for the three primary colors of light - Red, Green, and Blue. The combination of these colors in 

different proportions produces any color in the visible spectrum. RGB system is used for representing colors 

on computer display. 

http://drupal.org/
http://www.microsoft.com/visualstudio/en-us/default.mspx
http://www.yessoftware.com/
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HSL 

HSL stands for Hue, Saturation, and Lightness. It is a method for describing colors as they are perceived by 

a human eye. HSL is considered a more intuitive way of dealing with color than RGB.  

Hue corresponds to the actual color, saturation corresponds to the intensity, and luminosity corresponds to 

lightness of the color. 
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